Funde abrufen

-Gast-

Geomaster
Hi

benutze die neuesten nb.

es werden nicht alle funde geladen. bekomme immer 0 ergebnisse.
ein paar, die am gleichen tag waren, wurden aber beim 1. mal gefunden.

woran kann das liegen?
 

t31

Geowizard
Liegt in Regel daran, das du weniger als 6 Logs lädst, es müssen mehr als 5 also mindestens 6 sein, nur dann wird die komplette Seite mit allen Logs vollständig geladen und dein Name kann sicher gefunden werden.
 
OP
G

-Gast-

Geomaster
habs... hatte die maximalen updates auf 0

ich dachte das hieße unbegrenzt (so wie bei "entfernung" bei en filtern. war auch von haus aus eingetragen)
 

MiK

Geoguru
Das sollte aber keinen Einfluss auf das Laden von Caches haben, die noch nicht in der DB sind. Da steckt wohl noch ein Bug.
 

arbor95

Geoguru
t31 schrieb:
Liegt in Regel daran, das du weniger als 6 Logs lädst, es müssen mehr als 5 also mindestens 6 sein, nur dann wird die komplette Seite mit allen Logs vollständig geladen und dein Name kann sicher gefunden werden.

Das mit den 6 logs ist nicht (mehr) relevant. Es wird immer die Seite mit allen logs geladen (bei LadenAllFinds)
 

arbor95

Geoguru
-Gast- schrieb:
habs... hatte die maximalen updates auf 0

ich dachte das hieße unbegrenzt (so wie bei "entfernung" bei en filtern. war auch von haus aus eingetragen)
unbegrenzt ist Leer lassen oder -1 reinschreiben
(wie bei Anzahl auch)

Bei Anzahl geht es aber höchstens bis zur tatsächlichen Anzahl Funde.
 

arbor95

Geoguru
MiK schrieb:
Trotzdem sollten auch bei 0 Updates alle neuen geladen werden, oder?
Ja natürlich. Neue werden immer geladen. Dafür ist der Import ja da.

Wenn die gefundenen einmal im profil drin sind muss man sie ja nicht mehr updaten, auch wenn sich mal der Status von suchbar auf nicht mehr suchbar ändert. Man hat den Cache ja schon gefunden. Deshalb steht bei Updates der Defaultwert auf 0.
 
OP
G

-Gast-

Geomaster
araber95 schrieb:
MiK schrieb:
Trotzdem sollten auch bei 0 Updates alle neuen geladen werden, oder?
Ja natürlich. Neue werden immer geladen. Dafür ist der Import ja da.

Wenn die gefundenen einmal im profil drin sind muss man sie ja nicht mehr updaten, auch wenn sich mal der Status von suchbar auf nicht mehr suchbar ändert. Man hat den Cache ja schon gefunden. Deshalb steht bei Updates der Defaultwert auf 0.

Genau das funktionierte bei mir aber nicht ;)

(status auf nicht mehr suchbar ändern)

Erst als ich die updates auf einen Wert >0 gestellt habe, hat das Programm gecheckt, dass welche geupdatet wwerden müssen und mich gefragt, ob ich das will
 

arbor95

Geoguru
-Gast- schrieb:
araber95 schrieb:
MiK schrieb:
Trotzdem sollten auch bei 0 Updates alle neuen geladen werden, oder?
Ja natürlich. Neue werden immer geladen. Dafür ist der Import ja da.

Wenn die gefundenen einmal im profil drin sind muss man sie ja nicht mehr updaten, auch wenn sich mal der Status von suchbar auf nicht mehr suchbar ändert. Man hat den Cache ja schon gefunden. Deshalb steht bei Updates der Defaultwert auf 0.

Genau das funktionierte bei mir aber nicht ;)

(status auf nicht mehr suchbar ändern)

Erst als ich die updates auf einen Wert >0 gestellt habe, hat das Programm gecheckt, dass welche geupdatet wwerden müssen und mich gefragt, ob ich das will

Habe ich was anderes behauptet? Habe ich mich schwer verständlich ausgedrückt?
Updates = 0 --> es wird nichts upgedatet.

Im Klartext : Bei alle Funde steht da erst mal 0 und dann wird nicht upgedated, warum auch. Willst du einen gefundenen noch mal suchen und musst deshalb wissen, ob er noch suchbar ist????
 

MiK

Geoguru
Leute, die daraus Statistiken erzeugen, interessiert oft auch, wie viele der gefundenen Caches noch existieren.
 

arbor95

Geoguru
da in meinem Fundprofil auch bei einigen Cachen die ownlogid fehlte habe ich den Exporter um die Prüfung erweitert.
svn commit 2439

Bleibt dann nur noch die Prüfung auf Änderung von Type,Difficulty,Terrain und Size im Importer zu implementieren.
 

Lamima

Geocacher
Hi,

ich habe mir gerade die version 2444 installiert und damit Funde geladen, komischerweise läd er zwar die neuen gefundenen caches ordnungsgemäß, er setz aber nicht den Marker found bzw. das Datum.
Woran kann das liegen?

Gruß

Marco von Lamima
 

arbor95

Geoguru
Lamima schrieb:
Hi,
ich habe mir gerade die version 2444 installiert und damit Funde geladen,
schön
Lamima schrieb:
komischerweise läd er zwar die neuen gefundenen caches ordnungsgemäß
was will man mehr
Lamima schrieb:
er setzt aber nicht den Marker found bzw. das Datum.
bei den neuen?
Lamima schrieb:
Woran kann das liegen?
ich schau mal, aber bei mir geht das vermutlich!

Nachtrag : Es geht bei mir definitiv neue Funde über alle Funde laden zu importieren. Kein Problem zu sehen.


Wenn du mal 1-2 Cache im debug-Modus lädst und das Protokoll (log.txt) zur Verfügung stellst!?

Gruß

Marco von Lamima[/quote]
 

Lamima

Geocacher
So, 2 Stück geladen. Gleiches Verhalten: Er läd sie, setzt aber keinen Found-Marker bei den 2 neuen...

log:

02.02.2010/09:29:13.360: CW Version 1.1.2444 InDevelopmentNewest
02.02.2010/09:29:13.625: [login]:Fetching login page
02.02.2010/09:29:13.632: [fetch]:No Cookie found
02.02.2010/09:29:13.896: [fetch]:Connecting http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:15.216: [fetch]:Connect ok! http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:15.523: [fetch]:Read data ok http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:16.074: [login]:Eventvalidation not found before login
02.02.2010/09:29:16.125: [login]:Logging in as Lamima
02.02.2010/09:29:16.190: [fetch_post]:No Cookie found
02.02.2010/09:29:16.286: [fetch_post]:Connecting http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:17.937: [fetch_post]:Connect ok! http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:18.310: [fetch_post]:Read data ok http://www.geocaching.com/login/Default.aspx
02.02.2010/09:29:18.365: [login]:Login successful
02.02.2010/09:29:22.794: Getting first page: http://www.geocaching.com/seek/nearest.aspx?ul=Lamima
02.02.2010/09:29:22.916: [fetch]:Cookie Zeug: Cookie: ASP.NET_SessionId=ych4va55k05n0255bstjolad; userid=d177c918-0716-4b2d-b8fb-29277c0dfebe
02.02.2010/09:29:22.928: [fetch]:Connecting http://www.geocaching.com/seek/nearest.aspx?ul=Lamima
02.02.2010/09:29:25.096: [fetch]:Connect ok! http://www.geocaching.com/seek/nearest.aspx?ul=Lamima
02.02.2010/09:29:26.364: [fetch]:Read data ok http://www.geocaching.com/seek/nearest.aspx?ul=Lamima
02.02.2010/09:29:26.436: Got first page
02.02.2010/09:29:27.626: Checked 1 pages
02.02.2010/09:29:27.667: with 1 caches
02.02.2010/09:29:27.690: Found 2 new caches
02.02.2010/09:29:27.701: Found 0/0 caches for update
02.02.2010/09:29:27.721: Found 0 caches with no found in profile.
02.02.2010/09:29:27.767: Found 0 caches with changed archived status.
02.02.2010/09:29:27.791: Found 0 caches with changed available status.
02.02.2010/09:29:27.801: Found 0 caches with new found in log.
02.02.2010/09:29:27.814: Found 0 caches possibly archived.
02.02.2010/09:29:27.923: Found 0?=0 caches to update.
02.02.2010/09:29:27.992: Fetching: GC1AY6M
02.02.2010/09:29:28.033: [fetch]:Cookie Zeug: Cookie: ASP.NET_SessionId=ych4va55k05n0255bstjolad; userid=d177c918-0716-4b2d-b8fb-29277c0dfebe
02.02.2010/09:29:28.094: [fetch]:Connecting http://www.geocaching.com/seek/cache_details.aspx?wp=GC1AY6M&log=y
02.02.2010/09:29:30.766: [fetch]:Connect ok! http://www.geocaching.com/seek/cache_details.aspx?wp=GC1AY6M&log=y
02.02.2010/09:29:34.495: [fetch]:Read data ok http://www.geocaching.com/seek/cache_details.aspx?wp=GC1AY6M&log=y
02.02.2010/09:29:40.279: Too many logs. MAXLOGS reached (6)
02.02.2010/09:29:40.340: Got logs
02.02.2010/09:29:40.443: LatLon: N 50° 03.331 E 008° 22.476
02.02.2010/09:29:40.966: Got description
02.02.2010/09:29:41.230: Name: wiesbaden.travelnode.de
02.02.2010/09:29:41.498: Got location (country/state)
02.02.2010/09:29:41.736: Owner: stonewood; is_owned = false; alias1,2 = [Lamima|]
02.02.2010/09:29:42.665: Hidden: 2008-04-05
02.02.2010/09:29:46.380: Hints:
02.02.2010/09:29:46.609: Size: 4
02.02.2010/09:29:46.789: Hard: 10
02.02.2010/09:29:47.045: Terr: 15
02.02.2010/09:29:47.291: Type: 2
02.02.2010/09:29:47.370: Got TBs
02.02.2010/09:29:47.491: Writing file: pp1ay6m.xml
02.02.2010/09:29:48.093: Writing file: xp1ay6m.xml
02.02.2010/09:29:48.432: Got additional waypoints
02.02.2010/09:29:48.652: Got attributes
02.02.2010/09:29:48.801: ready GC1AY6M : 20100202092948

02.02.2010/09:29:49.051: Writing file: gc1ay6m.xml
02.02.2010/09:29:49.486: Fetching: GC1TF1P
02.02.2010/09:29:49.682: [fetch]:Cookie Zeug: Cookie: ASP.NET_SessionId=ych4va55k05n0255bstjolad; userid=d177c918-0716-4b2d-b8fb-29277c0dfebe
02.02.2010/09:29:49.819: [fetch]:Connecting http://www.geocaching.com/seek/cache_details.aspx?wp=GC1TF1P&log=y
02.02.2010/09:29:52.482: [fetch]:Connect ok! http://www.geocaching.com/seek/cache_details.aspx?wp=GC1TF1P&log=y
02.02.2010/09:29:54.896: [fetch]:Read data ok http://www.geocaching.com/seek/cache_details.aspx?wp=GC1TF1P&log=y
02.02.2010/09:30:00.206: Too many logs. MAXLOGS reached (6)
02.02.2010/09:30:00.255: Got logs
02.02.2010/09:30:00.377: LatLon: N 50° 03.421 E 008° 22.210
02.02.2010/09:30:03.002: Got description
02.02.2010/09:30:03.155: Name: Auf dem Weg zum Wandersmann.
02.02.2010/09:30:03.376: Got location (country/state)
02.02.2010/09:30:03.540: Owner: messer_mtk; is_owned = false; alias1,2 = [Lamima|]
02.02.2010/09:30:03.759: Hidden: 2009-01-05
02.02.2010/09:30:07.235: Hints:
02.02.2010/09:30:07.739: Size: 3
02.02.2010/09:30:08.561: Hard: 10
02.02.2010/09:30:08.998: Terr: 10
02.02.2010/09:30:09.578: Type: 2
02.02.2010/09:30:09.832: Got TBs
02.02.2010/09:30:10.021: Got additional waypoints
02.02.2010/09:30:10.052: Got attributes
02.02.2010/09:30:10.093: ready GC1TF1P : 20100202093010

02.02.2010/09:30:10.146: Writing file: gc1tf1p.xml
 

arbor95

Geoguru
super, danke für den log. Das passt soweit alles.

Mit dem TOO many logs, da muss ich noch mal ins Programm schauen!

Ist nur schade dass ich daraus nicht sehen kann warum er das gefunden nicht setzt.
Da wird immer so viel rausgeschrieben, aber das für diesen Fall relevante fehlt dann doch.
Ich schreib dir mal ne PN.
 

arbor95

Geoguru
schreib deinen alias mal neu in die Einstellungen rein.
mir ist es bisher nicht gelungen den Fehler mit dem
Too many logs. MAXLOGS reached (6) zu reproduzieren
 
OP
G

-Gast-

Geomaster
araber95 schrieb:
schreib deinen alias mal neu in die Einstellungen rein.
mir ist es bisher nicht gelungen den Fehler mit dem
Too many logs. MAXLOGS reached (6) zu reproduzieren

vermutlich hat er eingestellt, dass max 6 logs gespidert werden

anwendung->einstellungen->ansicht

(bisschen komische kategorie für diese einstellung...)

aber da seine logs recht neu sind, wird das nicht schuld am eigentlichen problem sein, er ist ja meist ganz oben
 
Oben