IOException in fetch

OrbitStar

Geocacher
Hi all,

habe mir gerade die java-Version des CacheWolfs auf meinem Linuxrechner aufgespielt.
Nach dem umschiffen der ersten Klippe (cd ins Prog.-Verzeichnis) habe ich jetzt aber das Problem das sich CW für's spidern nicht bei GC anmelden kann. :-(

Folgende Meldung(en) werden in log.txt festgehalten:
Code:
25.01.2010/18:27: CW Version 1.0.2409 Release
25.01.2010/18:27: Operating system: Linux/i386
25.01.2010/18:27: Java: Sun Microsystems Inc./1.6.0_0
25.01.2010/18:28: [login]:Fetching login page
25.01.2010/18:28: [fetch]:No Cookie found
25.01.2010/18:28: IOException in fetch
ewe.io.IOException: Could not connect
25.01.2010/18:28: [login]:Could not fetch: gc.com login page

Alias und passwort habe ich mehrfach geprüft und bin mir sicher das es daran wohl nicht liegt.
Internet ist definitiv erreichbar und GC kann ich auch via Browser von diesem Rechner nutzten.
Unter einer paralellen WinXP Installation funktioniert das Ganze ohne Probleme, aber die sollte eigentlich demnächts gelöscht werden.

Irgendwelche Ideen woran das mit dem Login unter Linux liegen kann??

Danke und Gruß,
OrbitStar
 

arbor95

Geoguru
Es könnte an der spider.def liegen, wenn dort eine falsche / keine Url für die Loginpage drin steht.

Schalt mal noch debug ein, dann kommen in dem fetch-Teil noch mehr Meldungen.
 

arbor95

Geoguru
mitlerweile gibt es einen schalter bei den Einstellungen!

Auf Deutsch heisst das glaub Fehlersuchmodus einschalten.

Manuell in der pref.xml geht es auch.
<debug value="true" />
 
OP
O

OrbitStar

Geocacher
In den Einstellungen kann ich nichts bezüglich eines "Fehlersuchmodus" finden. :-(

Auch das manuelle Hinzufügen des "debug" Eintrages führt nur dazu das die Informationen aus der log.txt auch auf der Komandozeile ausgegeben wird.

Was jetzt?
 
OP
O

OrbitStar

Geocacher
Hmm.... merkwürdig.
Habe mal auf die Schnelle mit WireShark auf die Netzwerke geschaut und gesehen das CW wohl via DNS die Adressen von OC bzw. GC abfragt, aber danach ist absolute Funkstille. :???:
Gibt's da irgendwas, bezüglich der Netzwerkinterface, bei der Konfig zu berücksichtigen?
Eigentlich funktionierts mit der Internetverbindung ohne Probleme.
 

MiK

Geoguru
Soweit ich weiß hat sich an der Stelle nicht viel geändert. Funktioniert denn der OC-Download? Laut Pfeffer werden dabei bei Netzwerkproblemen mehr Infos ausgegeben. Aber wenn der DNS nicht funktioniert, kann es natürlich nichts werden. Dann sind hier eher die Linux-Cracks gefragt. Das liegt bei mir zu lange zurück.
 
OP
O

OrbitStar

Geocacher
Nein, das Problem ist beim OC-Download das gleiche.
DNS funktioniert und es wird die Adressen auf aufgelöst
(212.2.32.87 für OC und 66.150.167.171 für GC)

Der Versuch bei GC bring die zuvor geposteten Einträge in der log.txt
Der Downloadversuch bei OC schlägt mit der Mitteilung "Fehler: Konnte Update-Dateien von opencaching.de nicht downloaden" fehl, ohne irgendetwas ins log zu schreiben. :???:

Gibt der 'debug' Mode mehr her und wenn ja wie schalte ich den in der Java-Version ein?
Das mit "<debug value="true" />" in der pref.xml bring die log-Meldungen auf die Konsole aber leider keine weiterne Details.
 

MiK

Geoguru
Wenn die Logausgabe auf der Konsole erfolgt, dann hast Du den Debug-Modus erfolgreich eingeschaltet. Mehr Ausgaben gibt die Version dann nicht her.
 
OP
O

OrbitStar

Geocacher
Ich hab dann nochmal das WLan Interface deaktiviert und via eth0 auf das Internet zugegriffen. Leider mit dem gleichen Fehlerbild. :nosmile:

Was kann ich noch tun um den Fehler einzugrenzen?
 

arbor95

Geoguru
ich würde dann erst mal ein NB installieren und damit probieren. Da kommen auf jeden Fall mehr Ausgaben.
 
OP
O

OrbitStar

Geocacher
Wo bekomme ich ein NB her?
Die CW Seite (http://www.naturalnik.de/cw-nightly.php) sagt da zu Zeit "Die Nightly Builds sind momentan aus Trafficgründen nicht verfügbar!" :???:
 

MiK

Geoguru
Hättest Du einfach mal nebenan im Thread zum Thema "NB-Server" nachgeschaut, dann wüsstest Du, dass es sie zur Zeit z.B. hier gibt: http://miksworld.de/cachewolf/NB/
 
OP
O

OrbitStar

Geocacher
Hab 'nur' unter "Installation von / of Nightly Builds (NB)" nachgeschaut. Asche über mein Haupt.

Nun habe ich die Dateien aus r2433 in die bestehende Installation kopiert und das ganze neu gestartet.

Der einzige, für mich zu erkennende, Unterschied ist, dass ein Download von OC jetzt auch eine IOException in einem seperaten Fenster ausgibt. :nosmile:

Wie bekomme ich es hin das da mehr 'Ausgabe' raus kommt?
 

arbor95

Geoguru
mehr als Ausgabe geht nicht, Für das login bei GC sieht das wie folgt aus.
Schau auf die Programmzeilen:
} else
pref.log("[fetch]:No Cookie found");
conn.setRequestorProperty("Connection", "close");
conn.documentIsEncoded = true;
pref.log("[fetch]:Connecting "+address);

Da wäre der Fehler dann bei :
conn.setRequestorProperty("Connection", "close");
conn.documentIsEncoded = true;
da ja die Ausgabe mit dem Connecting nicht kommt.

Aber das sind beides keine Sachen die eine IOException auslösen können.

Vielleicht schickst du ja mal einen log vom NB mit eingeschaltetem debug.

Von mir aus auch den vom OC oder besser beide.
 
OP
O

OrbitStar

Geocacher
Entschuldige meinen Frust aber welches log meinst Du??

Ich habe <debug value="true" /> in jede pref.xml eingetragen. (Prg-Verzeichnis und Profil-Verzeichnis)
Um eventuellen Rechteprobleme erstmal aus dem Wege zu gehen habe ich das ganze unter root installiert.
Die drei Dateien aus dem NB habe ich in das CacheWolf-Verzeichnis kopiert.
Beim 'download von OC kommt folgende Meldung in einem separaten Fenster sowie auf der Konsole:
Code:
http://www.opencaching.de/xml/ocxml11.php?modifiedsince=20050801000000&cache=1&cachedesc=1&picture=1&cachelog=1&removedobject=0&lat=50.18450&lon=008.29550&distance=2.0&charset=utf-8&cdata=0&session=0fetching
Jedoch keine Information in der log.txt.

Beim spidern von GC kommen folgende Meldungen auf der Konsole:
Code:
CW Version 1.1.2433 InDevelopmentNewest
Operating system: Linux/i386
Java: Sun Microsystems Inc./1.6.0_0
[login]:Fetching login page
[fetch]:No Cookie found
[fetch]:Connecting http://www.geocaching.com/login/Default.aspx
IOException in fetch
ewe.io.IOException: Could not connect
[login]:Could not fetch: gc.com login page
In der log.txt sieht das ganze dann so aus:
Code:
28.01.2010/17:45:30.679: CW Version 1.1.2433 InDevelopmentNewest
28.01.2010/17:45:30.710: Operating system: Linux/i386
28.01.2010/17:45:30.711: Java: Sun Microsystems Inc./1.6.0_0
28.01.2010/17:45:30.889: [login]:Fetching login page
28.01.2010/17:45:30.891: [fetch]:No Cookie found
28.01.2010/17:45:30.892: [fetch]:Connecting http://www.geocaching.com/login/Default.aspx
28.01.2010/17:45:31.170: IOException in fetch
ewe.io.IOException: Could not connect
28.01.2010/17:45:35.428: [login]:Could not fetch: gc.com login page
Auf dem Netzwerkmonitor sehe ich das jeweils eine DNS-Abfrage für OC bzw. GC gesendet wird und vom DNS-Server eine Antwort mit der jeweiligen IP-Adresse zurückkommt.
Danach ist Schluß auf dem Netzwerk und es erfolgt anscheinend kein Versuch eine Verbindung zur angegebenen IP-Adresse aufzubauen. :nosmile:

Sollte in irgendeiner anderen Datei mehr Information stehen?
 
Oben