• Willkommen im Geoclub - dem größten deutschsprachigen Geocaching-Forum. Registriere dich kostenlos, um alle Inhalte zu sehen und neue Beiträge zu erstellen.

c:geo - Aktuelle Bugs

DNF_BLN

Moderator
Teammitglied
So mal kein aktuelles Bug, auf diesem Wege ein Dankeschön an das c:geo Team für eure Arbeit und Mühe in diesem Jahr. Ich freue mich schon auf 2022 mit c:geo.

Schöne Weihnachten und einen Guten Rutsch.

DNF_BLN
 

malek

Geocacher
Hallo Zusammen

Erst einmal ein RIESEN GROSSES DANKESCHÖN für Eure super Arbeit!!

Und dann ... nun ja, eigentlich ist es wahrscheinlich kein c:geo Bug aber ich probiere es trotzdem:

Ich verwende eigentlich seit 'immer' die HERE maps (aktuell HERE WeGo) auf dem Mobiltelefon ... schon zu Symbian Zeiten war es eine gute, kostenlose Navigationssoftware mit gutem Kartenmaterial und mit der Möglichkeit Offline Karten zu verwalten.

Seit dem letzten App Update ist erstens die Oberfläche katastrophal schlecht geworden, aber noch viel unangenehmer ist, dass die Navigation zu Wegpunkten aus c:geo heraus nicht mehr funktioniert. Es wird einfach das Ziel nicht mehr sauber übergeben.
Nachdem es mit GMaps noch funktioniert, wird es wohl nicht an c:geo liegen, aber evtl. kann man doch irgend 'etwas' machen?

Wenn ich statt Navigation (Fahren) oder Navigation (Fahrrad) 'Andere externe App' auswähle, werden die Koordinaten interessanterweise 'korrekt' übergeben aber leider auch der Cache Name in Klammer hintendran ... womit die Zielnavigation auch nicht direkt ohne herumzutippen gestartet werden kann.

Es wäre super, wenn ihr da evtl. mal einen Blick darauf werfen könntet.
Danke & l'g
 
Moin,moin

Benutze c:geo Vers.2021.12.24 unter Android 8.0.0.

Bisher konnte man Wegpunkte von Lab-Stationen in der Adventure App per blauem Navigationspfeil nach „Ziele“ in c: geo exportieren.
Fand ich sehr praktisch, weil ich mit der Karte der Adv.App nicht soviel anfangen konnte.
Der Export klappt immer noch, allerdings übernimmt nun c:geo den Stationsnamen nicht mehr sondern trägt „undefined“ ein.
Wenn man dieses Ziel bearbeiten möchte, geht zwar das Bearbeitungsmenü auf aber sobald man in das Kästchen “ Name“ tippt, schließt sich das Menüfenster wieder.
Was ist zu tun ? :irre:
 

SammysHP

Geoguru
Das ist ein bekanntes Problem. Leider handelt es sich dabei um einen Fehler der Adventure App, auf die wir keinen Einfluss haben.

https://github.com/cgeo/cgeo/issues/12427

Für das Problem mit dem Bearbeiten des Namens: Könntest du uns dazu bitte deine Systeminfos (unter "über c:geo") und vielleicht einen Screenshot der Stelle schicken? Gerne auch mit kurzer Fehlerbeschreibung an support@cgeo.org.
 
SammysHP schrieb:
Das ist ein bekanntes Problem. Leider handelt es sich dabei um einen Fehler der Adventure App, auf die wir keinen Einfluss haben.

https://github.com/cgeo/cgeo/issues/12427

Für das Problem mit dem Bearbeiten des Namens: Könntest du uns dazu bitte deine Systeminfos (unter "über c:geo") und vielleicht einen Screenshot der Stelle schicken? Gerne auch mit kurzer Fehlerbeschreibung an support@cgeo.org.


Danke für die schnelle Antwort.
Mail an Support ist eben raus.
 

_moses_

Geonewbie
Hallo Zusammen

Erst einmal ein RIESEN GROSSES DANKESCHÖN für Eure super Arbeit!!

Und dann ... nun ja, eigentlich ist es wahrscheinlich kein c:geo Bug aber ich probiere es trotzdem:

Ich verwende eigentlich seit 'immer' die HERE maps (aktuell HERE WeGo) auf dem Mobiltelefon ... schon zu Symbian Zeiten war es eine gute, kostenlose Navigationssoftware mit gutem Kartenmaterial und mit der Möglichkeit Offline Karten zu verwalten.

Seit dem letzten App Update ist erstens die Oberfläche katastrophal schlecht geworden, aber noch viel unangenehmer ist, dass die Navigation zu Wegpunkten aus c:geo heraus nicht mehr funktioniert. Es wird einfach das Ziel nicht mehr sauber übergeben.
Nachdem es mit GMaps noch funktioniert, wird es wohl nicht an c:geo liegen, aber evtl. kann man doch irgend 'etwas' machen?

Wenn ich statt Navigation (Fahren) oder Navigation (Fahrrad) 'Andere externe App' auswähle, werden die Koordinaten interessanterweise 'korrekt' übergeben aber leider auch der Cache Name in Klammer hintendran ... womit die Zielnavigation auch nicht direkt ohne herumzutippen gestartet werden kann.

Es wäre super, wenn ihr da evtl. mal einen Blick darauf werfen könntet.
Danke & l'g
Hallo - erst auch einmal von mir ein riesiges Dankeschön an euch. c:geo ist für mich die einzige echt gute App zum Cachen. Leider hab auch ich das Problem mit der Here Maps und hege (trotzdem daß die App mittlerweile echt schlecht geworden ist) eine kleine Hoffnung daß die Koordinatenübergabe irgendwie mit vertretbarem Aufwand wieder zum Laufen zu bringen ist.

Vielen Dank und Gruß
_moses_
 

DerRadler

Geonewbie
Hi,
ich habe ein Problem mit c:geo, das ich zuerst versucht habe auszusitzen (kann ja jemand anders berichten ;-). Es beißt mich aber immer wieder und inzwischen glaube ich, dass es vielleicht nicht so viele c:geo Benutzer mit einer derart schlechten Mobilfunkabdeckung gibt wie mich. Ich wohne im "Silicon Valley" Deutschlands (Haha!), dem Stuttgarter Raum, und drei Kilometer von meinem Haus entfernt im Naturpark Schönbuch gibt es keinen Mobilfunk Empfang, nicht mal auf der Bundesstraße und nicht mal nur zum Telefonieren.

Das Problem, das ich mit c:geo habe, ist folgender Hergang: Ich bin ohne Mobilfunkempfang, will einen Cache anschauen, der lokal gespeichert ist, c:geo sagt mir, dass das Anmelden fehlgeschlagen ist oder dass ich nicht angemeldet werden kann, und dann kommt "die Details werden geladen" oder "lade Cache Details". Und das geht nie mehr weg. Ich kann das Laden abbrechen, einen anderen Cache probieren, wieder hängt es im Laden der Details. Das war einmal extrem frustrierend, weil ich eine halbe Stunde geradelt bin um den Cache zu loggen, der lokal gespeichert ist, und dann kam ich nicht an die Details um nachzuschauen, was hier zu tun ist.

Wieder zuhause konnte ich - mit Mobilfunk - die Cache Details laden. Und wenn ich in den Flugmodus gegangen bin (= keinerlei Netz), dann ging es auch. Ich spekuliere dass c:geo vorher irgendwie rausfindet, ob es überhaupt eine Verbindung zum Server probieren soll und im Flugmodus ist das ein klares Nein. Aber im Wald ohne Mobilfunk aber mit mobilen Daten aktiviert probiert es vielleicht die Verbindung und wartet dort bis in alle Ewigkeit.

Die App schließen und wieder aufrufen hilft nichts. Inzwischen bin ich auf den Trick gekommen, dass ich dem Android sagen kann, es soll die App beenden. Dann wird sicherlich der Cache (nicht geo-Cache ;-) gelöscht. Wenn ich dann erst in den Flugmodus gehe und dann c:geo start und es noch einmal probiere, dann kann ich das lokal gespeicherte Cache Listing anschauen.

Ich kann mir vorstellen, dass Ihr Entwickler das gar nicht so einfach reproduzieren könnt. Vermutlich müsst Ihr einen Raum mit Abschirmung suchen, in dem Ihr keinen Mobilfunk Empfang habt. Es wäre aber toll, wenn Ihr Euch das mal anschauen könntet. Ich benutze c:geo solange ich zurück denken kann und bin immer wieder begeistert. Es war schon immer große Klasse und ist immer noch besser geworden. Als mir das neulich im Wald passiert ist, konnte ich es gar nicht glauben. Aber es ist mir seitdem wieder und wieder passiert. Gestern zum letzten Mal. Meine Version ist 2022.03.10.

Herzliche Grüße, Frank der Radler
 

FamJobig

Geocacher
Ich habe bei einem Cacherkollegen einen Bug gesehen den ich nicht verstehe.
Gleiche Software Version (aktuell), ähnliches Samsung Handy.
Bei seinem liesen sich die eigenen Cache auf der Karte nicht ausblenden.
Laut seinen Aussagen hat er sogar die App schon mal gelöscht und wieder installiert.
er hat auch keine Caches offline gespeichert etc.
Was könnte er noch tun?
Danke
 

SammysHP

Geoguru
Da fehlen leider zu viele Informationen, um diese Frage beantworten zu können. Wir benötigen für eine Diagnose mindestens die Systeminformationen aus "Über c:geo" aus dem Menü vom Startbildschirm.
 

FamJobig

Geocacher
Da fehlen leider zu viele Informationen, um diese Frage beantworten zu können. Wir benötigen für eine Diagnose mindestens die Systeminformationen aus "Über c:geo" aus dem Menü vom Startbildschirm.
Wir haben beide die Version 2022.06.06 installiert. Wobei laut seinen Ausagen der Bug schon längere Zeit besteht
 

DNF_BLN

Moderator
Teammitglied
Hat dein Trick denn unter Android 12 mal funktioniert? Wenn ja, ist danach ein Android 12 Update gekommen und seit dem geht das nicht mehr. Um welches Handy/Hersteller handelt es sich. Hat der Hersteller ein Update bereitgestellt, ist irgendetwas an seiner eigenen Hersteller UI verändert worden?
Das sollte man erstmal prüfen und bedenken. Oftmals ändert der Hersteller im Hintergrund etwas an seiner eigen UI und man bekommt das gar nicht mit.
 

Vio-la

Geocacher
Hat dein Trick denn unter Android 12 mal funktioniert? Wenn ja, ist danach ein Android 12 Update gekommen und seit dem geht das nicht mehr. Um welches Handy/Hersteller handelt es sich. Hat der Hersteller ein Update bereitgestellt, ist irgendetwas an seiner eigenen Hersteller UI verändert worden?

Danke dass du dir das angesehen hast.

Ich zitiere mal aus dem anderen Thread:

Ich weiß nicht ob es daran liegt, dass ich die App Better open with installiert habe (die jedenfalls mit cgeo ja gerade nicht mehr funktioniert, siehe den vorherigen Post), jedenfalls wird mir auf meinem Smartphone (Galaxy S10, aktuelle Android Version), wenn ich einen Internet-Link aufrufe, immer auch Locus zusätzlich zu den auf meinem Handy installierten Browsern zur Auswahl angezeigt. Locus habe ich installiert ebenso wie cgeo, nutze es nur nicht.

Woran liegt das denn, dass Locus da angeboten wird und cgeo nicht? Kann man das evtl ändern?

Anscheinend wird c:geo jetzt nicht mal mehr von "better open with" als "Browser-app" erkannt - ist das vielleicht die Ursache?
Dazwischen hat es kein (für mich erkennbares) Android-Software-Update gegeben, aber ich gehe gehe davon aus, dass es dazwischen zB ein Update vom Samsung-Browser gegeben haben könnte (wahrscheinlich ist das das Entscheidende).

Der Trick bestand darin, dass ich vor Jahren die App BetterOpenWith installiert habe, weil Android keine App-Auswahl mehr angeboten hat.

Bis vor ein paar Tagen wurden (von BetterOpenWith, das nehme ich jedenfalls an, denn ansonsten funktioniert diese App weiterhin wie sie soll) als "Browser" zum Öffnen jeweils die Internetbrowser angeboten die ich auf dem Handy installiert habe (Samsung, Chrome, Firefox) und in einem 2. Schritt, also wenn ich dann den Samsung Browser ausgewählt habe, zusätzlich noch Locus und cgeo. (Meistens öffne ich Cachelistings aus den GS Notification Mails, also wird das der Standardfall gewesen sein)

Seit ein paar Tagen, ohne dass ich mir einer Änderung der Einstellungen bewusst wäre, wurden da nur noch Samsung, Chrome, Firefox und dann Locus zur Auswahl angeboten, aber nicht mehr cgeo. (siehe das Zitat aus dem anderen Thread)
Daher dachte ich, man könnte vielleicht etwas an cgeo machen, weil dasselbe mit Locus weiterhin funktionierte, aber plötzlich nicht mehr mit cgeo.

Und gerade eben habe ich es auf deinen Beitrag hin nochmal ausprobiert:
Wenn ich einen Link zu einem Cachelisting aus einer Notification-Mail (gmail) von GS öffnen will, werden mir nun nur noch die 3 Internetbrowser angeboten, einen 2. Schritt gibt es nicht mehr.
Wenn ich einen Link zu einem Cachelisting aus einer Word-Datei öffnen will, werden mir die 3 Internetbrowser und Locus und cgeo angezeigt.
 

SammysHP

Geoguru
Viele E-Mail-Apps beinhalten einen Linkschutz, sodass die Links nicht direkt geöffnet werden. Vielleicht ist das bei dir auch der Fall?

Leider gibt es bei Android immer weniger Möglichkeiten, auf Links zu reagieren. Meistens muss man sich jetzt für eine App entscheiden, die dann immer genutzt wird. Das geht auch nicht mehr so flexibel wie früher. Da Caches über normale URLs aufgerufen werden, geht das schnell mal direkt an den Browser.
 
Oben