Keine neuen Caches downloadbar?

Axel2

Geocacher
Hallo,

ich kann keine neuen Caches mehr von Geocaching.com downloaden. Ist das bei Euch auch so?
Getestet mit:
Cachewolf 1.0.2409 und
Cachewolf 1.1.2524
Windows XP

Caches aktualisieren funktioniert.

Fehlerbild:
Cachewolf versucht Caches zu laden, sagt ganz kurz: "0 Caches" (kann aber nicht stimmen) und zeigt dann die unveränderte Liste an.

Debug-Output: Siehe Anhang.

Axelcw.png
 

klausundelke

Geowizard
...liegt vermutlich wieder mal am Update der GC-Seite, welches ja gestern vorgenommen wurde.
Warte einfach mal 3-4 Tage, bisher haben die Entwickler immer relativ kurzfristig Updates für CW bereitgestellt die das Problem wieder beheben.
 
OP
A

Axel2

Geocacher
klausundelke schrieb:
...liegt vermutlich wieder mal am Update der GC-Seite, welches ja gestern vorgenommen wurde.

Ah, danke für die Info; wußte ich nicht.
Dann brauche ich den Fehler wenigstens nicht bei mir suchen.

Schönen Feiertag,
Axel
 
OP
A

Axel2

Geocacher
Mit geänderter spider..def bekomme ich jetzt wieder die Caches.
Aber noch nicht die Hints :/

Änderungen:
Code:
#--------------------------------------
#Section1: First page with list of caches
#--------------------------------------
firstPage          = http://www.geocaching.com/seek/nearest.aspx?lat=
firstPage2         = &lng=
firstPageFinds     = http://www.geocaching.com/seek/nearest.aspx?ul=
# Regex to search for cachenames
listBlockRex       = <table id="ctl00_ContentBody_dlResults"((?s).*?)</table>
# lineRex            = <tr\ bgcolor='#.{6}'\ class="Data\ BorderTop">((?s).*?)</tr> # -Axel 2010-04-02
lineRex            = <tr\ bgcolor='#.{6}'\\s+class="Data\ BorderTop">((?s).*?)</tr>
directionRex       = /compass/(.*?).gif
logDateRex         = <td>(.*?)<br\ /><span\ class="Success">
availableRex       = <span\ class="Strike">
archivedRex        = <span\ class="Warning Strike">
PMRex              = small_profile.gif
# distRex            = <br\ />(.*?)(?:km|mi)</td> # -Axel 2010-04-02
distRex            = <br\ />(.*?)(?:km|mi)\\s+</td>
waypointRex        = \\(GC(.*?)\\)<br\ />
# TypeRex            = k"><img\ src="/images/WptTypes/(.*?)\\.gif # -Axel 2010-04-02
TypeRex            = k">\\s+<img\ src="/images/WptTypes/(.*?)\\.gif
SizeRex            = /container/(.*?)\\.gif
# DandTRex           = <td>\\((.*?)/(.*?)\\)<br # -Axel 2010-04-02
DandTRex           = <td>\\s+\\((.*?)/(.*?)\\)<br
found              = alt="Found\ It!"
own                = /WptTypes/name_tag.gif
TBRex              = /wpttypes/([0-9]+).gif" alt="(.*?)"
showOnlyFound      = &f=1
maxDistance        = &dist=
firstLine          = http://www.geocaching.com/seek/nearest.aspx?lat=
firstLine2         = &lng=
nextListPage       = /seek/nearest.aspx
 

Gavriel

Geocacher
bei mir passiert auch nichts (nb 2533).
war ja zu erwarten, dass wieder irgendwas sinnloses am design geändert wird. auch ohne cw geht gc bei mir nur noch im schneckentempo
 

Geo-Johnny

Geowizard
Axel2 schrieb:
Mit geänderter spider..def bekomme ich jetzt wieder die Caches.
Aber noch nicht die Hints :/

Änderungen:
Code:
#--------------------------------------
#Section1: First page with list of caches
#--------------------------------------
firstPage          = http://www.geocaching.com/seek/nearest.aspx?lat=
firstPage2         = &lng=
firstPageFinds     = http://www.geocaching.com/seek/nearest.aspx?ul=
# Regex to search for cachenames
listBlockRex       = <table id="ctl00_ContentBody_dlResults"((?s).*?)</table>
# lineRex            = <tr\ bgcolor='#.{6}'\ class="Data\ BorderTop">((?s).*?)</tr> # -Axel 2010-04-02
lineRex            = <tr\ bgcolor='#.{6}'\\s+class="Data\ BorderTop">((?s).*?)</tr>
directionRex       = /compass/(.*?).gif
logDateRex         = <td>(.*?)<br\ /><span\ class="Success">
availableRex       = <span\ class="Strike">
archivedRex        = <span\ class="Warning Strike">
PMRex              = small_profile.gif
# distRex            = <br\ />(.*?)(?:km|mi)</td> # -Axel 2010-04-02
distRex            = <br\ />(.*?)(?:km|mi)\\s+</td>
waypointRex        = \\(GC(.*?)\\)<br\ />
# TypeRex            = k"><img\ src="/images/WptTypes/(.*?)\\.gif # -Axel 2010-04-02
TypeRex            = k">\\s+<img\ src="/images/WptTypes/(.*?)\\.gif
SizeRex            = /container/(.*?)\\.gif
# DandTRex           = <td>\\((.*?)/(.*?)\\)<br # -Axel 2010-04-02
DandTRex           = <td>\\s+\\((.*?)/(.*?)\\)<br
found              = alt="Found\ It!"
own                = /WptTypes/name_tag.gif
TBRex              = /wpttypes/([0-9]+).gif" alt="(.*?)"
showOnlyFound      = &f=1
maxDistance        = &dist=
firstLine          = http://www.geocaching.com/seek/nearest.aspx?lat=
firstLine2         = &lng=
nextListPage       = /seek/nearest.aspx
Yep, damit geht es. Aber wie erwähnt, ohne Hints ...
Naja, MiK wird es wieder fixen denk ich mal. Ich kenne mich leider zu wenig aus.
:eek:ps:
 

MiK

Geoguru
Danke an Axel für die ersten Hinweise. Ich habe sie leicht verändert übernommen. Außerdem habe ich auch die Hints angepasst. Im nächsten NB ist das alles drin. Bitte ausführlich testen!
 

Geo-Johnny

Geowizard
Danke MiK, im Namen aller CW-User. ;)
Wann cirka kommt das neue NB auf den Server?
Ich hole mir das immer von hier http://placebox.naturalnet.de/~nik/cw-nightly.php, passt das? Bin z.Z. nicht ganz am Laufenden. :eek:ps:
 

MiK

Geoguru
Wo es die aktuellen NBs gibt, findest Du in meiner Signatur (bzw. in dem dort verlinkten Thread). Mittlerweile gibt es dort auch die Version mit den neuesten Änderungen.
 
OP
A

Axel2

Geocacher
Was bedeutet eigentlich:

Code:
(?s)

in den RegExpen? Kenne ich so nicht...

Axel
 

Gavriel

Geocacher
Klasse, mit der 2434 funktionierts wieder.
Hat sich an den "Seiten", die da abgeklappert werden, etwas verändert? Ich habe meinen gewohnten Radius gespidert, da wäre mir noch nie aufgefallen, dass das 26 Seiten lang ist.
 

MiK

Geoguru
Musste ich auch erst mal wieder nachschauen:

www.regular-expressions.info schrieb:
(?s) Turn on "dot matches newline" for the remainder of the regular expression. (Older regex flavors may turn it on for the entire regex.)
 

MiK

Geoguru
Vielleicht noch ein paar andere Rückmeldungen? Geht wirklich alles wieder? werden alle Informationen richtig geladen?
 

Geo-Johnny

Geowizard
MiK schrieb:
Vielleicht noch ein paar andere Rückmeldungen? Geht wirklich alles wieder? werden alle Informationen richtig geladen?
Soweit ich es verfolgt habe, dürfte es passen. Aber ich scanne äußerst wenig, bin also vielleicht kein ausreichendes Maß. Nochmals Danke für Deinen Blitzeinsatz ;)
 

MiK

Geoguru
Für 1.0.x Nutzer:
Ihr könnt einfach eine neue spider.def laden:
http://svn.berlios.de/svnroot/repos/cachewolf/branches/bugfix_1.0/res_noewe/spider.def

Und damit die vorhandene ersetzen. Komplettpakete zum Download gibt es erst am Dienstag.
 
Oben